Home > Android, Linux/Unix, Opensource > Android Nexus5x Updates: FAILED (remote: buffer overreads occured due to invalid sparse header)

Android Nexus5x Updates: FAILED (remote: buffer overreads occured due to invalid sparse header)

nexusWieder einmal beim Basteln gewesen und bin auf nachdem ich durch war, dabei gewesen Updates auf dem alten Weg zu installieren, sprich nicht ueber OTA Files und Flashfire sondern via Fastboot und Factory Images.
Warum?
War eben gerade so, doch so einfach wollte es nicht funktionieren, Ausgangssystem war ein Ubuntu 15.10 mit offiziellen Repos und installierten Android Tools aus der Ecke.
Quittiert wurde dies jedoch mit einem:

sending sparse 'system' (516666 KB)...
FAILED (remote: buffer overreads occured due to invalid sparse header)

Abhilfe schaffen hier nur neue Android-SDK Tools, also Plattform Tools runterladen, da keine Pakete existieren: https://dl.google.com/android/android-sdk_r24.4.1-linux.tgz waere die aktuelle Version.
Danach in eine Verzeichnis auspacken und ggf. folgede Exports setzen und fire:

.-(~/android-sdk)------------------------------------------------(t4c@cwpc0971)-
`--> export ANDROID_HOME=/home/t4c/android-sdk
.-(~/android-sdk)------------------------------------------------(t4c@cwpc0971)-
`--> export ANDROID_HOME=/home/t4c/android-sdk
export PATH=$PATH:$ANDROID_HOME/tools:$ANDROID_HOME/platform_tools
.-(~/android-sdk)------------------------------------------------(t4c@cwpc0971)-
`--> android update sdk --no-ui --filter platform-tools,tools

Danach klappts dann auch wieder mit dem Nachbarn, denn der Bug ueber den ich hier stolpere ist in den aktuellen Fastbootversionen gefixed, lolbuntu kommt da nur leider nicht nach.

Ähnliche Posts

  1. Bisher keine Kommentare
  1. Bisher keine Trackbacks